FileVoyager as Default File Manager

Home Forums Feature requests FileVoyager as Default File Manager

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #4535

    Hey Folks!

    New here, found FV through the ‘Portable Apps’ site.

    Before and above all: FileVoyager is absolutely amazing – congrats to the author for a job very well done!

    Used Directory Opus before, but FileVoyager wins hands down!

    I know, that’s probably no easy task, but to launch FV through, say, [Win]+[E] would be absolutely fantastic.

    I will certainly put it in Autostart though.

    OK, it’s more of a comfort issue (no problem if it’s not practical to do) but that would really rock – imho 😉

    Kind regards from Switzerland!



    Hi Charles,

    Thank you for your kind words and welcome to this forum!

    To answer your question, I considered the possibility of replacing the default File Explorer. However, replacing File Explorer is challenging and can compromise some core Windows’ functionalities.

    A better approach, as you suggested, would be to override the [win]+[E] shortcut.
    I came across an easy and safe way to do it by reading a article.

    It is highly likely that I will implement this approach in FileVoyager in the futur
    Alternatively, you can also follow the steps below:

    1. In your favorite text editor, create a .reg file. Say FileVoyagerWinE.reg
    2. copy and paste these commands into the file :

      Windows Registry Editor Version 5.00
      [HKEY_CURRENT_USER\SOFTWARE\Classes\CLSID\{52205fd8-5dfb-447d-801a-d0b52f2e83e1}\shell\opennewwindow\command]@=”C:\\Progam Files (x86)\\FileVoyager\\FileVoyager.exe

    3. Replace the path, in bold above, with the path on your system. Be sure to use double backslashes “\\” instead of a sigle one “\”.
    4. Execute FileVoyagerWinE.reg

    No need to reboot, your [win]+[E] shortcut is launching FileVoyager now.

    To reset the default [win]+[E] behaviour, just delete the CLSID key from your registry:

    1. Launch Regedit.exe
    2. Navigate to HKEY_CURRENT_USER\SOFTWARE\Classes\CLSID\{52205fd8-5dfb-447d-801a-d0b52f2e83e1}
    3. Delete the key

    No need to reboot, your [win]+[E] shortcut is launching the default File Explorer.


    Hi Keymaster

    Many thanks for your thorough answer plus the Registry-Key provided – much appreciated!

    I created this file and ran it against the registry, which, based on a message, seemed to be successful.

    Trying it out, the following happened:

    When entering [Win]+[E], the still installed Directory Opus (DOpus) launched. What is remarkable is, that even though I had configured DOpus’s Settings to replace the standard Windows File Manager, it never worked – only after your registry script. Isn’t that funny 😀?

    I then removed said setting in DOpus and when entering [Win]+[E] again, it was Windozes lousy standard file manager that opened. I guess, that the same will happen, when I go and un-install DOpus…

    I also stopped DOpus completely but that didn’t help it either. With said setting it launched DOpus and without it M$’s file manager was launched …

    I then checked the registry to see if the above registry script did show up correct by searching for said class ID {52205fd8-5dfb-447d-801a-d0b52f2e83e1} .

    Well, it did show up in several instances under the ‘\CLSID\’ hive. but most entries were set to ‘Standard’ and a few referred under ‘DelegateExecute’ to the class ID, mentioned above.

    I also tried to place the last line of the script (@=”C:\\Progam Files (x86)\\FileVoyager\\FileVoyager.exe” ) on a separate line (as in the linked example from, bur that didn’t help either..

    So, what did I miss 🤔 Thanks for your further thoughts on this matter!

    And please let me know if I can help with some more troubleshooting on this!

    Kind regards from Switzerland!




    Hi Charles,

    After some research, I propose you do this:

    1. Launch Regedit.exe
    2. Navigate to HKEY_CURRENT_USER\SOFTWARE\Classes\CLSID\{52205fd8-5dfb-447d-801a-d0b52f2e83e1}
    3. Delete the key

    When done, re-execute the .reg script you created based on the initial post of this thread.

    My assumption is that the “HKEY_CURRENT_USER\SOFTWARE\Classes\CLSID\{52205fd8-5dfb-447d-801a-d0b52f2e83e1}\shell\open” still refers to the default behaviour (File Explorer) and is executed prior to falling back on the “opennewwindow” key. By resetting the whole CLSID 52205fd8-5dfb-447d-801a-d0b52f2e83e1, we can start on a clean base.

    If this doesn’t work, I must confess I don’t have any other idea 😶


    Hi Keymaster

    Again, many thanks for your feedback!

    Well, it didn’t help, sorry.

    Although it seems that you seem to be, generally speaking, on the right track. But there’s perhaps yet another key storing this info re. default file manager…

    I was able to solve the aspect re DOpus: There were two different settings in it, both controlling the <Win>- E key issue. After setting both preferences, it’s the deplorable windoze file manager which consistently shows up…

    Anyway, thanks for your inputs on this and please keep up the excellent work you do with FileVoyager!



    Hi Charles,

    While I may not be able to address the root cause of your problem, I do have a workaround to suggest. Have you heard of AutoHotkey? This application allows you to automate complex tasks using keyboard combinations.
    I tested overriding the Win+E pair with AutoHotkey and it worked like a charm on my machine. If you’d like to give it a try, here are the steps:
    1. Go to and download the V2.0 (don’t search it on google because some fake ones are better referenced)
    2. Install the software and it will start up on the Dash
    3. Select “New script”, give it a name, optionally select “Minimal for v2”, and click “Create” (by default, the file will be saves in your Document folder in an AutoHotkey subfolder)
    4. Open the .ahk file from the folder mentioned above in your preferred file editor (notepad, notepad++, PSPad, SublimeText, …)
    5. add the following line after the default one (if any):
      #e::run “C:\Program Files (x86)\FileVoyager\FileVoyager.exe”
      (Note: the command between quotes is here pointing to FileVoyager, but you can choose any program you want and add command-line parameters as well)
    6. Save the file, but keep it open in your editor so that you can quickly make changes if necessary.
      (Note: each time you make changes to the file, you must save it and double-click it from your preferred file manager to apply the changes. AutoHotkey will ask you if you want to override – accept this.

    Hi Keymaster

    Awesome! This really works – many thanks for this workaround – much appreciated!

    The only ‘small’ caveat is that it launches FileVoyager anew, each time when pressing <WIN>-E, even though it is already running (minimized into the system tray). Well,  I can live with that, no sweat.

    I wonder, if there’s a script for detecting if a given app is already running and showing that instead of launching it anew.

    I’ll let you know if/when I find a solution on the AHK-website.

    Thanks again and kind regards from Switzerland (home of the Swiss Army Knife ☺)




    Hi Charles,

    Good news: I’ve implemented the Single Instance capability in FileVoyager a couple of days ago.
    I’ll probably release a version this weekend with this.

    Stay tuned!


    Hi Keymaster

    Terrific news – thanks for that!

    Have a nice weekend!




    FileVoyager 23.5.7 is now live and has Single Instance capability.
    Even if command line parameters are passed to a new instance that is about to be closed, the parameters will be received and processed by the Single Instance functionality in the current open instance.

    Thanks Charles for the active contribution 👍


    Hi Keymaster

    Thanks you very much for this update – everything is working like a charm!

    Glad to be of help! Please let me know if/when I should test something.

    Have a nice evening and kind regards from Switzerland!


    P.S: I will modify the German translation a bit – it’s not bad at all, but some expressions used therein are a bit long-winded IMHO.

    Let me download this dktranet utility and make a few suggestions to further improve the german language file. I will then, if you allow, send the file over to you.


Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.

Comments are closed.